Delay of message sent status
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted 21 days ago. Nov 25, 2018 - 19:12 PST
Monitoring
Due to the volume of promotions being sent over the Black Friday weekend, delivery status updates will be delayed. Please contact support by phone, email or chat with any questions.
Posted 24 days ago. Nov 23, 2018 - 05:53 PST