Customer support line is down
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted 6 months ago. May 15, 2018 - 15:26 PDT
Monitoring
The support line is up again. Our provider has identified and corrected the issue. Thank you for your patience.
Posted 6 months ago. May 15, 2018 - 14:05 PDT
Investigating
We apologize, but our customer support line is currently down. For now, please email us at support@fivestars.com or chat us from your customer dashboard at http://dashboard.fivestars.com. Our phone provider is currently investigating the issue. Sorry again for the inconvenience.
Posted 6 months ago. May 15, 2018 - 13:18 PDT