A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2022 - 08:31 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 13, 2022 - 08:08 PDT
Investigating
We are currently investigating an issue preventing some calls to be routed to a Customer Care Representative. We have Chat Reps standing by to assist, which can be reached at http://dashboard.fivestars.com/