Pay Server outage. High Latency and potential credit card failures
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 14:48 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 01, 2022 - 14:27 PDT
Investigating
We are currently investigating this issue.
Posted Jul 01, 2022 - 14:17 PDT