Payments failure issue

Incident Report for FiveStars

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 14:32 PDT

Identified

We’re currently investigating an issue affecting payments on our POS devices. Payments may not go through at this time.

Our teams have identified the issue and are actively working to resolve it. We’ll provide an update as soon as we have more information.

We’re sorry for the disruption and appreciate your patience.
Posted Jul 23, 2026 - 10:17 PDT