Outage

Incident Report for FiveStars

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 11:06 PDT

Update

The issue has been identified affecting our internal systems and a fix is being implemented.
Posted Apr 18, 2025 - 10:35 PDT

Investigating

We are currently experiencing an outage affecting inbound and outbound calls. Our team is actively working to resolve this issue as quickly as possible. For real-time updates, please visit this site.

We apologize for any inconvenience caused and appreciate your patience.

Thank you,
Posted Apr 18, 2025 - 09:23 PDT