Phone lines are currently down.
Incident Report for FiveStars
Resolved
Phone lines are working now.
Posted 11 days ago. Nov 09, 2018 - 12:47 PST
Update
We are continuing to investigate this issue.
Posted 11 days ago. Nov 09, 2018 - 12:46 PST
Investigating
Phone lines are currently down. We are currently investigating the issue. Please reach us on chat from dashboard or at the following link, https://business-support.fivestars.com/s/. You can also email us at support@fivestars.com
Posted 11 days ago. Nov 09, 2018 - 11:49 PST