Processing on FirstData (Clover)
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 12:15 PST
Update
We are continuing to investigate this issue.
Posted Feb 26, 2021 - 11:30 PST
Investigating
We sincerely apologize as we're experiencing an issue affecting merchants processing on FirstData (Clover) are experiencing failed transactions. We understand the importance of getting this service up and running again and our Engineering team is working to resolve it as soon as possible. Thank you for your patience. We will continue to post updates here as soon as we can.
Posted Feb 26, 2021 - 11:02 PST