Customer support phone lines not working
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 13:36 PDT
Monitoring
A fix has been implemented and we are now receiving inbound calls.
Posted Mar 12, 2024 - 12:16 PDT
Identified
Issue has been identified and we are currently working on a fix.
Posted Mar 12, 2024 - 11:47 PDT
Investigating
Our phone lines went down about half an hour ago, we are working to restore our lines as soon as possible. Please check back on this page for updates on when we restore our service, additionally you can email support@fivestars.com or chat with us for service in the meantime. We appreciate your patience.
Posted Mar 12, 2024 - 11:36 PDT