Phone lines currently down
Incident Report for FiveStars
Resolved
Phone lines are back online. We appreciate your patience.
Posted 7 days ago. Oct 09, 2018 - 10:01 PDT
Investigating
Phone lines are currently down. We are currently investigating the issue. Please reach us on chat from dashboard or at the following link, https://business-support.fivestars.com/s/. You can also email us at support@fivestars.com
Posted 7 days ago. Oct 09, 2018 - 09:21 PDT