Users experiencing queue with 'something went wrong' screen

Incident Report for FiveStars

Resolved

This incident has been resolved.
Posted May 04, 2026 - 10:26 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 04, 2026 - 08:52 PDT

Investigating

We are currently investigating an issue causing some customer tablets to display a “Something went wrong” message. Our team is actively working to resolve this as quickly as possible. We appreciate your patience and will share updates as they become available.
Posted May 04, 2026 - 08:20 PDT