Payment Processing Outage
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 09:15 PDT
Investigating
Approximately 30% of transaction attempts are timing out. This will cause an error experience in store. We are currently investigating.
Posted Aug 09, 2022 - 05:55 PDT