Customer support line is busy or unreachable
Incident Report for FiveStars
Resolved
We have confirmed this issue is resolved.
Posted 8 months ago. Mar 15, 2018 - 08:56 PDT
Monitoring
The problem seems to be resolved but we are continuing to monitor the issue.
Posted 8 months ago. Mar 15, 2018 - 07:16 PDT
Identified
The problem was identified late last night and we are awaiting on our carrier for resolution.
Posted 8 months ago. Mar 14, 2018 - 11:17 PDT
Investigating
Some customers are experiencing trouble reaching our customer support line. This number can be used to reach our customer support team temporarily (720) 330-3464. Our carrier is working on this issue. Thanks for your patience.
Posted 8 months ago. Mar 13, 2018 - 15:18 PDT