Phone lines are currently down
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 26, 2019 - 08:33 PST
Update
Issue has been resolved
Posted 4 months ago. Feb 26, 2019 - 08:32 PST
Investigating
Phone lines are currently down. We are currently investigating the issue. Please reach us on chat from dashboard or at the following link, https://business-support.fivestars.com/s/. You can also email us at support@fivestars.com
Posted 4 months ago. Feb 26, 2019 - 05:47 PST