Pay Server Issue
Incident Report for FiveStars
Resolved
This issue is now resolved. Merchants should no longer see a declined message. If your issue continues please call Support at 415-266-5995.
Posted Nov 02, 2019 - 12:18 PDT
Identified
We are currently an issue with out Pay Servers. The issue is causing cards to be shown as declined. We have identified the issue. Our engineering team is working to resolve this issue quickly.
Posted Nov 02, 2019 - 11:19 PDT