Dashboard Login
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 02, 2019 - 16:10 PDT
Identified
We are currently experiencing an issue with new logins to our Merchant Dashboard ( https://dashboard.fivestars.com ) This may also limit Fivestars Support issue resolution. Our operations team is working to resolve the situation.
Posted 14 days ago. Sep 02, 2019 - 10:16 PDT