We are currently experiencing a Pay Server Outage
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted May 06, 2022 - 10:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2022 - 09:36 PDT
Investigating
We are currently experiencing a Pay Server Outage which may cause Credit Card Transactions to fail. We are currently investigating this issue.
Posted May 06, 2022 - 07:33 PDT