Phone Lines currently down
Incident Report for FiveStars
Resolved
Phone lines are back in service. We appreciate your patience.
Posted about 1 month ago. Oct 19, 2018 - 13:06 PDT
Monitoring
Phone lines are back in service. We appreciate your patience as we monitor for any continuing issues.
Posted about 1 month ago. Oct 19, 2018 - 12:16 PDT
Investigating
Phone lines are currently down. We are currently investigating the issue. Please reach us on chat from dashboard or at the following link, https://business-support.fivestars.com/s/. You can also email us at support@fivestars.com
Posted about 1 month ago. Oct 19, 2018 - 10:43 PDT