Pay Merchants- Delay in Bank Deposit
Incident Report for FiveStars
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 14:24 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 22, 2020 - 06:59 PST
Identified
There was an incident with servers that caused one business day funding delay for some merchants. If you have not received your deposit, it will be deposited tomorrow along with tomorrow's scheduled deposits. We apologize for any inconvenience this may have caused.
Posted Dec 22, 2020 - 06:58 PST